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Following are our most downloaded ebooks for career
advancement:

#1 Sales & ROI Accelerator (151+ pages)

WHAT'S INSIDE: My step-by-step Blueprint (151 Pages) For Generating
Record Sales And ROI By Leveraging Analytics Data.

#2 Set Up Your Google Analytics 4 (GA4) Account Correctly And Fast (70 pages)

WHAT'S INSIDE: Learn to set up your GA4 account correctly and fast using

this 62 points checklist.

FAQ: Do you show “How” to do each item on the checklist? If so, with

screenshots?

Yes. There are links to the articles with detailed step by step instructions.

FAQ: Does this ebook cover GTM too?

Yes.

#3 Google Tag Manager Data Layers (100+ pages)

WHAT'S INSIDE: My step-by-step blueprint for getting started with data
layers. Get the only ebook on GTM data layers ever published. Learn the

JavaScript behind it.

#4 Learn to Read Ecommerce Reports in Google Analytics (100+ pages)

WHAT'S INSIDE: My step-by-step guide to reading both standard and
enhanced ecommerce reports in Google Analytics. Ecommerce reports are

the most valuable reports in Google Analytics.
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#5 Do you want better skills in digital analytics and marketing? If yes, then

register for the free training:

Here’s what we’re going to cover...

1. Why digital analytics is the key to online business success.

2. The number 1 reason why most marketers are not able to scale their
advertising and maximize sales.

3. Why Google and Facebook ads don’t work for most businesses & how to
make them work.

4. Why you won’t get any competitive advantage in the marketplace just by
knowing Google Analytics.

5. The number 1 reason why conversion optimization is not working for your
business.

6. How to advertise on any marketing platform for FREE with an unlimited
budget.

7. How to learn and master digital analytics and conversion optimization in

record time.

Get helpful tips on a daily basis

If you are the type of person who finds it helpful to receive short tips on building
your website traffic, improving conversions, fixing attribution issues and learning
about analytics in general, then follow me on LinkedIn. | post a few short tips each
day.

Click here and follow me on LinkedIn
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This checklist will help you greatly in setting up your Google Analytics account

pretty fast.

GA4 Setup Planning

At this stage you plan out exactly:

1.
2.

N o v kW

What data you will collect (tracking requirements)

What is required to get the desired data (implementation setup requirements) and
whether getting the desired data is technically feasible (technical feasibility study)
How you will collect the data (functional and technical designs)

How the tags would be deployed (tag deployment planning)

How the data should be processed

How the data should be reported.

Risk assessments — risk associated with tag deployment and the project in general

(including tag auditing).

Many marketers/analysts skip the planning stage and jump straight into the implementation

phase which could result in a lot of: rework, missed deadlines, additional cost, disappointment,

disagreement, conflicts, lawsuits and war with the clients, especially if the implementation

project is big and a lot of money is at stake.

| would suggest creating a project scope document at this stage which clearly outlines:

1.
2.
3.

Project Plan - How you will carry out the project.

Project deliverables - The results your project will produce.

Project Exclusions - What results your project will not produce. This is important to
mention. Otherwise, you can implement ‘N’ things in GA4 and your project can
practically run forever.

Project milestones - What will be the key milestones and estimated time frame for each

milestone.
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Project Requirement - What is required in order to carry out this project. Outline all the

tools, permissions and support you would need in order to carry out this project.

6. Project Assumptions - What are the assumptions under which this project will be
carried out?

7. Project Constraints/risk - Outline all the risks which could derail your project or stop you
from completing a particular project deliverable.

8. Project cost and terms of work - Mention both fixed and variable costs if the project

scope is not crystal clear.

GA4 Basic Setup

Plan the structure of your GA4 account

e How many Google Analytics Accounts do you need?
e How many GA4 Properties do you need?
e How many GA4 views do you need?

For step by step instructions, check out this article: Google Analytics Account Hierarchy

(structure explained)

Upgrade to GA4 (Google Analytics 4)

CASE-1: If you already have a GA3 property (aka Universal Analytics property) then

follow the steps mentioned in the following link to create a new GA4 property: CASE-1

CASE-2: If you already have a GA4 property then you already have access to the GA4
property. Now all you have to do is to connect your GA4 to your GA3 property by

following the steps mentioned in the following link: CASE-2
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CASE-3: If you are installing Google Analytics tracking for the first time and you want to
install both GA4 and GA3 on your website at the same time then follow the steps

mentioned in the following link: CASE-3

Set up filtered views in GA4

If you want to create a filtered reporting view in GA4 and you have access to GA4 360

(paid version of GA4) then create a sub property. A sub property is like a typical GA4

property, but it gets its data from another property (also called the source property).

For step by step instructions on creating sub properties in GA4, check out this article:

Google Analytics 4 Sub Properties Tutorial

Set up rollup property in GA4

A roll-up property is a special type of GA4 property whose event data comes from other
GA4 properties (also known as source properties). When you use a roll-up property you
can easily and automatically measure the overall performance of your websites/apps
without manually exporting and aggregating data from different GA4 properties over

and over again.

Create a rollup property in the following cases:

e You want to understand the overall performance of the company that runs
several websites and/or mobile apps to promote various brands/regional
business units.

e You want to compare the performance of individual brands/ business units to

each other.
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For step by step instructions on creating roll-up properties in GA4, check out this

article: Roll up Property in Google Analytics 4 (GA4) — Tutorial

Add app data streams to GA4 property

We use Firebase to add mobile app data streams to our GA4 property. In order to use
Firebase, you would need to create and use one or more projects. These projects are
called Firebase Projects. In order to send mobile app data to your GA4 property, you

would need to link your Firebase project to your GA4 property.

For step by step instructions on adding app data streams to your GA4 property, check

out this article:_.GA4 Firebase Integration — Correctly add App data streams to GA4
property

Set up Enhanced Measurement Tracking in GA4

Through the ‘Enhanced Measurement Tracking’ feature you can automatically track file
downloads, scrolling, clicks on outbound links, clicks on video play buttons, site search

etc sitewide.

For step by step instructions on enabling GA4 enhanced measurement tracking, check

out this article: GA4 (Google Analytics 4) Enhanced Measurement Tracking Tutorial

Activate Google Signals for your GA4 property

Google Signals is an advertising reporting feature through which GA4 can collect
cross-device data from those website users who have signed in to one of their Google

accounts (Gmail, YouTube, etc) and have turned on ad personalization.
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When you set up Google Signals for your GA4 property, you can:
® More accurately track users across different devices and platforms.
e Remarket to more website users across devices.

e Analyze users’ data by age, gender and interest.

Demographics overview B o ; tassmdms Nov1-Now2e. 2020 = [ <

ors = by Gender Users = by Interests Users = by Age

Withod‘tyG'oogIe Signals

Users = by Gondor Users = by Age

Demographics overview & @ ~ withGoogIe Sig“als

For step by step instructions on activating Google Signals for your GA4 property, check

out this article: Google Signals GA4 — See demographics (gender, age) in Google

Analytics 4

Exclude internal traffic in GA4

There is always a good possibility that you and your staff may be inflating your own
website traffic data by visiting your website every day or so. Internal traffic is the traffic
coming from you, your employees, suppliers and other service providers to your

website.
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These people are not your target audience and therefore we don’t need to track them.
Internal traffic can easily inflate your website usage metrics (sessions, page views, time

on site etc) and therefore should be filtered out from your GA4 reports.

For step by step instructions on excluding internal traffic from your reporting in GA4
property, check out this article: Excl internal traffic in GA4 le Analytics 4) vi

IP filter

Connect your GA4 property with Google Ads

Universal Analytics relied on the traditional session-based goal format that we have
known for years. These session-based goals were the only way to import user
interactions into the Google Ads data. With the limitation of 20 goals per reporting view,
it was rather tough to define and configure the audience for the best campaign

performance.

This problem is now solved with the advent of GA4. Google Analytics 4 uses an
event-based model which means that you can configure more key user interactions into

your Google Ads account without firing a conversion tag for individual actions.
Now you can define your audience in a more detailed manner based on events like a
scroll, file download, video play, and custom events. This is main the advantage of linking

your GA4 property with your Google Ads account.

For step by step instructions on linking your GA4 property with Google Ads, check out

this article: How to link GA4 (Google Analytics 4) with Google Ads
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Set Up Site Search Tracking in GA4

Through the GA4 site search feature, you can determine the search terms used by your
website visitors to find information on your website. Site search is automatically tracked

in GA4 property once you enable the enhanced measurement feature.

But site search tracking will only work on default query parameters defined by Google. If
your website uses any parameter, other than one of the default parameters (q, s, search,
query, keyword) in its URL, you would need to additionally configure a custom

parameter to fire the event.

For step by step instructions on configuring custom search query parameters for GA4

site search tracking, check out this article: GA4 Site Search — Tracking Site Search in
Google Analytics 4

Set up Scroll Tracking in GA4

Scroll tracking allows you to measure how website users are engaging with your content.
Scroll tracking is also automatically tracked in GA4 property once you enable the

enhanced measurement feature.

But by default, GA4 tracks only 90% of scroll depths. Also, GA4 only tracks vertical scroll

events with no parameter collected for the event.
If you want to set up scroll events for lower thresholds (10%, 25%, 50% and 75%) or

horizontal scroll tracking then you would need to set up custom events via Google Tag

Manager.
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For step by step instructions on setting up scroll tracking in GA4, check out this article:

GA4 (Google Analytics 4) Scroll Tracking Tutorial

Import conversions from GA4 property to your Google
Ads account

Following are the key advantages of importing GA4 conversions into Google Ads:
e You can access your Google Analytics conversions and data related to your
Google Ads clicks.
e You can see Google Analytics conversion data in Google Ads.
® You can give Google Ads Smart Bidding, access to data that helps optimize bids,

potentially increasing conversions and lowering costs.

For step by step instructions on importing conversions from your GA4 property to your

Google Ads account check out this article: How to import conversions from GA4
property to your Google Ads account

Connect your GA4 property with Google Search Console

You would need to link your GA4 property to your Google search console account.
Through such integration, you can view the Google search console data (queries,
impressions, clicks, CTR, landing pages etc) in the Search Console reports of your GA4

reporting view.

Google search console provides data about what users see in Google search results
before they decide to click on your website. You can use this data to identify
opportunities and prioritize development efforts to increase the number of visitors to

your website.
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For step by step instructions on connecting your GA4 property to your Google Search

Console account, check out this article: How to link Google Search Console to Google

Analytics 4 (GA4)

Set up Cross Domain Tracking in GA4

In the case of Universal Analytics, a complicated setup was required to set up the
cross-domain tracking. It was usually done by using the ‘allowlinker’ parameter

hardcoded into every single GTM tag or in every ‘gtag.js’ (Global Site Tag) call.

In the case of GA4, setting up cross-domain tracking has been made very simple and no
hardcoded tagging is required like in the earlier version. It can now be achieved with

only configuration settings in the ‘Admin’ section.

For step by step instructions on setting up cross-domain tracking in GA4, check out this

article: Cross Domain Tracking in GA4 (Google Analytics 4) Setup Guide

Connect your GA4 property with BigQuery

Unlike Universal Analytics, GA4 comes with a free connection to BigQuery. So you can
access the raw GA4 data and run SQL queries on it. This helps in more precise and
multilevel data analysis of your users so that it is easy to understand the user activities

on the website.

When you use BigQuery, you can manipulate Google Analytics data in a way which is

many times simply not possible by using the Google Analytics user interface.

For step by step instructions on connecting your GA4 property with BigQuery, check

out this article: GA4 BigQuery — Connect Google Analytics 4 with BigQuery
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[J Transfer GA3 (Universal Analytics) data into GA4

Both GA3 and GA4 use different data schemas. Because of that, it is not possible to

transfer your GA3 data into your GA4 property. But there is a workaround.

You can transfer both your GA3 and GA4 data into BigQuery and then manipulate it
there. GA4 provides a free connection to BigQuery but GA3 does not (unless you use
GA360). However, with the help of a third-party solution/connector, it is possible to send

data from GA3 to BigQuery without using GA 360.

For step by step instructions on sending your GA3 data to BigQuery, check out this
article: Sending data from Google Analytics to BigQuery without 360

[J Save your Universal Analytics data from being deleted

As you know with the sunset of Universal Analytics, Google will most likely delete all of
your historical universal analytics data in 2023. If you want to save your historical GA3

(Universal Analytics) data from being deleted then export it into BigQuery.

By backfilling Google Analytics data in BigQuery, you can export historical data into your
BigQuery project. ‘Supermetrics for BigQuery’ connector allows you to backfill up to six
months’ worth of data at one time. If you want to backfill more data then you would

need to do it in separate batches of six months sized.

For step by step instructions on saving your universal analytics data from being

deleted, check out this article: How to backfill Google Analytics data in BigQuery
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Setup GA4 test property

A Google Analytics 4 property comes with only one reporting view. So whenever you
change one of the settings of your GA4 property, you permanently change the way the

data is collected, processed and reported in your reporting view.

Every change you make to your GA4 property setting(s) has the potential to permanently
inflate/skew your current analytics data. So you need to create a separate GA4 property

just for testing purposes. We call this property a GA4 test property.

For step by step instructions on setting up your GA4 test property, check out this

article: Using the GA4 (Google Analytics 4) Test Property

Setup referral exclusion in GA4

Google Analytics 4 allows you to set condition(s) that identifies unwanted referrals and
prevent them from being reported as referral traffic. This way you don’t see the referral
traffic from certain domains (like your own domain or from a payment gateway like

PayPal) in your GA4 reports.

In the earlier version of Google Analytics (Universal Analytics) this functionality was
called the referrals exclusion list. Now in the case of GA4, the ‘referral exclusion list’ is

known as the “List unwanted referrals”

For step by step instructions on setting up referral exclusion in GA4, check out this

article: Self-referral Google Analytics 4 — Referral exclusion GA4
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Install Google Analytics 4 on Shopify

Before getting started, make sure that you have set up your Google Analytics 4 property

and Shopify account.

For step by step instructions on installing GA4 in your shopify account, check out this

article: How to Install Google Analytics 4 on Shopify

GA4 Intermediate Setup

Set up UTM tracking in GA4

UTM tracking refers to the tagging of your website URL with UTM parameters. Through
UTM tracking, you can send detailed information about a marketing campaign to GA4.

For step by step instructions on setting up UTM tracking in GA4, check out this article:

utm_source, utm_medium, utm_campaign Parameters — GA4 (Google Analytics 4)

Create landing pages report in GA4

By default, GA4 does not provide the landing pages report. You need to create this
report from scratch if you want to use it. You can determine the top landing pages for
your website through the landing pages report.

For step by step instructions on creating the landing pages report, check out this

article: How to Create Landing Pages Report in GA4 (Google Analytics 4)
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Create Google Ads report in GA4

A GA4 property does not provide any pre-built report to measure the performance of
Google Ads. But you can create this report from scratch by using the exploration report
templates.

For step by step instructions on creating the Google Ads report, check out this article:

How to create Google Ads report in GA4 (Google Analytics 4)

Create organic search traffic analysis report in GA4

A GA4 property does not provide any pre-built report to measure the performance of
organic search traffic. But you can create this report from scratch by using the
exploration report templates. This new report would have nine tabs. Each tab would
display one sub-report, which measures the performance of organic search traffic to the
website.

For step by step instructions on creating the Google Ads report, check out this article:

Organic Search Traffic Analysis in GA4 — Complete Guide

Set up GA4 Custom Events

An event is the user’s interaction/activity with a web page element embedded on a
website and/or mobile app. There are four categories of events in GA4:

1. Automatically collected events

2. Enhanced measurement events
3. Recommended events
4

Custom events
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Custom events are the events that you create and use. Custom events can be any
interaction on your website that is not tracked by default. For example, button click, sign

up events, form submission, etc.

For step by step instructions on setting up GA4 custom events via GTM, checkout this

article: How to set up GA4 Custom Events via Google Tag Manager

Rename Events in GA4

While implementing events in GA4 there might be some typos or tagging mistakes that
need to be fixed. You can achieve this by renaming the events. Another example would
be if you want to modify the event parameters and your GA/GTM developer is out of

reach. In such a case you can complete this task by event modification in GA4.

For step by step instructions on renaming events in GA4, checkout this article: How to

rename events in Google Analytics 4 (GA4)

Use the debug view report in GA4

The DebugView report allows you to monitor your website’s event data in real-time
along with all the custom parameters and user properties set. When you are setting up
or debugging your GA4 implementation, it is a best practice to use the GA4 debug

report.

For step by step instructions on using the debug view report in GA4, checkout this

article: How to use DebugView report in Google Analytics 4 (GA4)
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Set Up Goal Conversion Tracking in GA4

Goals measure how well your website fulfils your target objectives. Your website goals
can be something like which graduate programs are viewed the most, how many users

contact the student service, how many are contacting guidance and admissions etc.

Defining Goals is a fundamental component of any digital analytics measurement plan.
Having properly configured Goals allows Google Analytics to provide you with critical
information, such as the number of conversions and the conversion rate for your
website. Without this information, it's almost impossible to evaluate the effectiveness of

your website and marketing campaigns.

For step by step instructions on setting up conversion tracking in GA4, check out this

article: Google Analytics 4 Conversion Tracking Guide — GA4 Goals

Setup Content Grouping in GA4

A content group is a set of web pages that are based on the same theme. So in the case
of a blog, a content group can be a set of web pages that are based on the same topic
e.g. Google Tag Manager. In the case of an ecommerce website, a content group can be

a set of web pages that sell similar products e.g. shirts.

Through content grouping in GA4, you can quickly check the performance of a content

group or compare the performance of different content groups with each other.

Content groups allow you to measure the performance of a set of web pages at the

content category or product category level.
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Content grouping is especially useful if you have got a big website with hundreds or
thousands of web pages and you can realistically measure the web pages performance,

only at the group level and not at the individual page level.

For step by step instructions on setting up content grouping in GA4, check out this

article: Google Analytics 4 Content Grouping — Create Content Groups in GA4

Create User properties in GA4

User properties are attributes that are used to define segments of your user base, such
as language preference or geographic location. By default, Google Analytics 4

automatically logs some user properties like the ones below:

User dimension Type Description

Age Text Identifies users by six categories: 18-24, 25-34, 35-44, 45-54,
55-64, and 65+,

Country Text The country the user resides in.

Device Category Text The category of the mobile device (e.g. mobile or tablet).

Device Model Text The mobile device model name (e.g. iPhone 5s or SM-JS00M).

Gender Text Identifies users as either male or female,

Interests Text Lists the interests of the user (e.g. “Arts & Entertainment,
Games, Sports™).

Language Text The language setting of the device OS (e.g. en-us or pt-hr).

In the context of GA4, the user properties are user scoped custom dimensions.
User-scope means the value of the custom dimension is calculated and sent once for

each user.

Google recommends that you use a user-scoped custom dimension when you want to

identify static or slowly changing attributes of your website/app users like changes in the

subscription plan, membership level, game difficulty level, etc.
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For step by step instructions on creating user properties in GA4, check out this article:

GA4 User Properties (User Scoped Custom Dimensions) — Tutorial

Create custom insights in GA4

It is extremely difficult to keep an eye on significant variations in your website traffic or
any of your marketing campaign/traffic sources manually and that too 24/7. Here is

where GA4 custom insights come in handy.

Through GA4 custom insights you can monitor significant variations in your website
traffic and marketing campaigns. Whenever such variation occurs you get an email alert

from Google asking you to take immediate action.

Custom insights are generated when traffic reaches a specific threshold that you have
specified. For example, if your website traffic dropped by more than 90% in comparison
to the last day, then you can get an alert via email from Google. Without setting up such

an alert, you may never know when the website tracking stopped working.

Similarly, if your website sales dropped by more than 50% in comparison to the last
week, then you can get an alert via email from Google. Without setting up such an alert,

you may never know when your marketing campaigns started underperforming.

For step by step instructions on creating custom insights in GA4, check out this article:

How to create custom insights in Google Analytics 4 (GA4)

Create remarketing audiences in GA4

You would need to set up Remarketing audiences in your GA4 property. Remarketing

audience is a list of users to which you want to show one or more targeted ads. We can
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also create a remarketing audience based on user behaviour (like users who abandoned

the shopping cart, users who purchased item X etc).

Once you have created the remarketing audiences in GA4, these audiences will be
available in your Google Ads account for retargeting. You can then run remarketing
campaigns in Google Ads using these GA4 Audiences. Remarketing campaigns have

proved to increase the ROl for many businesses and are almost always profitable.

For step by step instructions on creating remarketing audiences in GA4, check out this

article: How to create a remarketing audience in Google Analytics 4 (GA4)

Build comparisons (advanced segments) in GA4

In GA4, comparisons take the place of segments and filters that you’ve used in Universal
Analytics properties. Just like segments, comparisons allow you to isolate and analyze a
subset of data. For example, if you want to compare the behavior of desktop and mobile

users in GA4, you can do that via GA4 comparisons.

For step by step instructions on building comparisons in GA4, check out this article:

How il mparison van ments) in le Analytics 4 (GA4

Create custom audiences in GA4

In the context of GA4, an audience is a group of users that you can club together based
on any combinations of attributes or experiences in a particular time frame. The
audiences feature in GA4 allows you to segment your users based on the dimensions,

metrics, and events important to your business.
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For step by step instructions on creating custom audiences in GA4, check out this

article: GA4 Audiences — Creating custom audience in Google Analytics 4

Create Audience Triggers in GA4

The Audience Triggers in GA4 fire an event when users match the definition of an
audience and become members. By using GA audience triggers you can create complex

events (conversions) in GA4.

For example, you can not define the following user activity as a conversion in GA3
(Universal Analytics): “A user that visited your website via your newsletter and then
watched a 5 minutes long video before making a purchase that is above 5100.”

But in GA4, you can create such type of complex conversion via ‘Audience Trigger’.

For step by step instructions on creating audience triggers in GA4, check out this

article: Understanding Audience Triggers in Google Analytics 4 (GA4)

Upload data from external data sources via GA4 Data
Import

Through data import feature in GA4, you can upload data from external data sources
(like point of sale, offline data, CRM data, etc.) to your GA4 property. For example, if you
run a business that generates leads online but sales happen in a physical shop (offline),
you can track conversions in Google Analytics by uploading the transaction data from

the offline system.

For step by step instructions on uploading data from external data sources in GA4,

check out this article: GA4 (Google Analytics 4) Data Import Tutorial
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GA4 Advanced Setup

Set up predictive metrics in GA4

With predictive metrics, you can identify users and their actions on the website that will
likely lead to a purchase or conversion. This will help you to discover more users who can

purchase the product in the next 7 days.

For step by step instructions on setting up predictive metrics in GA4, check out this

article: What are predictive metrics in Google Analytics 4 (GA4)

Create Predictive Audiences in GA4

Predictive audiences in GA4 help you classify users who are likely to perform a certain
action in the near future. A predictive audience is based on the conditions of a

predictive metric (like purchase probability, churn probability, and revenue predictions).

Here are a few examples of predictive audiences:
e Likely 7-day purchasers: Users who are likely to purchase in the next 7 days.
e Likely first-time 7-day purchasers: Users who are likely to make their first
purchase in the next 7 days.
e Likely 7-day churning users: Active users who are likely to not visit your website
in the next 7 days.
e Likely 7-day churning purchasers: Purchasing users who are likely to not visit

your website in the next 7 days.

Copyright Optimize Smart 2023 Page 27


https://www.optimizesmart.com/what-are-predictive-metrics-in-google-analytics-4-ga4/

=8 OptimizeSmart.com

For step by step instructions on creating predictive audiences in GA4, check out this

article: Google Analytics 4 (GA4) Predictive Audiences — Tutorial

Set up Ecommerce Tracking in GA4

If you run an online store where ecommerce transactions take place, you cannot just
depend upon the analytics reports provided by your shopping cart. You would need GA4

e-commerce tracking set up for your website.

It is only by using ecommerce tracking that you can correlate sales data with website
usage data (like traffic source/medium, landing pages etc). Such type of correlation
analysis is required in order to understand the performance of your website landing

pages and marketing campaigns.

Otherwise, you may never know which landing pages or campaigns are driving sales and
which are not. Through e-commerce reports in GA4 you can get detailed information
about e-commerce activity on your website like total revenue generated by the website,

the number of orders placed, average order value, e-commerce conversion rate etc.

For step by step instructions on setting up ecommerce tracking in GA4, check out this

article: GA4 le Analytics 4) Ecommerce Tracking via GTM — T

Set up Enhanced Ecommerce Tracking in GA4

Enhanced ecommerce tracking is currently not available in GA4
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Set up Sales funnels in GA4

In GA4, a funnel is a navigation path (series of web pages) that you expect your website
visitors to follow to achieve website goals. Through funnels, you can determine where
visitors enter and exit the conversion/sales process. You can then determine and
eliminate bottlenecks in your conversion/sales process in order to improve the website

conversion rate. Following is an example of sales funnels in GA4:

A | . GA4 - Google Merchandise Store
< . Q T hing "Insights™
o Analyties G4~ Google Merchandise Store 1Y searehing nsions

] o Funnel explor.. ~ +
m Step Step2 Step 3 Step4 Step 5
First open/visit 100%  Organic visitors 37.5% Session start 22.5%  Screen/Page view 65%  Purchase
©
Q . -
: =] 0 _
W MK 62.5% W 19K 77.5% W 2K 35% W 3.6K 100%

Step Device category Users (% of Step 1) Completion rate Abandonments Abandonment rate
1. First open/visit Total 66,119 (100.0%) 37.5% 41,329 62.5%

desktop 39,840 (100.0%) 41.1% 23,481 58.9%

We can create a sales funnel in GA4 via the Funnel exploration report.

For step by step instructions on setting up sales funnel in GA4 via the exploration

report, check out this article: How to use the Funnel Exploration Report in GA4

(Google Analytics 4) — Funnel Analysis

Export data from GA4 to BigQuery

You can export all of the events from GA4 to BigQuery and then use SQL-like syntax to
query the data. Below are few reasons why you should consider exporting data to

BigQuery:
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e You can perform advanced analysis on the raw data from GA4 property.
e You can pull data into BigQuery from multiple data streams (Android apps, 10S
apps, and website).

e You can join your data with other marketing or CRM tools.

For step by step instructions on exporting GA4 data into BigQuery, check out this
article: How to connect and export data from GA4 to BigQuery

Backfill GA4 data in BigQuery

Backfilling GA4 data in BigQuery means importing historical GA4 data into your BigQuery
project. If you are like me, you may have been collecting data in your GA4 property for
years. But if you have only recently connected GA4 with BigQuery, you may not have all

the historical data in your BigQuery project.

This is because, by default, the GA4 data is imported to BigQuery only from the date you
first connected your GA4 property to your BigQuery project. If you want historical GA4

data in your BigQuery project, then you would need to backfill GA4 data in BigQuery.

For step by step instructions on backfilling GA4 data in your BigQuery project, check

out this article: How to backfill GA4 data in BigQuery

Send custom GA4 data to BigQuery

When you send data from a GA4 property to BigQuery, you use the default schema (i.e.
structure) provided by Google. As a result, Google automatically created a set of tables

(‘events_‘ and ‘events_intraday_‘) in the pre-built dataset (“analytics_<property_id>“).
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You do not get the option of creating the data tables you want or setting the fields you
want to see in the data table(s). If you want to see your data tables with only the fields

you want then you need to first create your own schema (also called Custom Schema).

For step by step instructions on sending custom GA4 data to BigQuery, check out this

article: BigQuery GA4 schema — Send Custom GA4 Data to BigQuery

Track Single Page Apps in GA4

Single-page applications (SPAs) are web-based applications or websites that load all the
content required for the page on the initial load. As the users interact with the website,
subsequent content is loaded dynamically, which means there is no refresh and the

Google Analytics tags fire only once.

For step by step instructions on tracking single page apps in GA4, check out this article:

How to track single page apps in Google Analytics 4 (GA4

Setup GA4 via GTM Server Side Tagging

FAQ: How do | track users' data correctly when Google Analytics, Google Tag Manager

and/or third-party cookies are being blocked by users' web browsers?

You probably know that the Brave web browser blocks both Google Analytics and GTM
by default. An increasing number of users are now using ad blockers. To make the matter
worse, Google also announced a plan to end the support of third-party cookies in the

near future. Web browsers continue to restrict access to more and more users' data.

All of these tracking restrictions are creating big data gaps on the conversion paths and

making it very difficult to understand customers' purchase journeys and advertise
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profitably. So how do you track users' data then? One efficient way of tracking data is to

use server side tagging.

There is a common misconception that server-side tracking can be blocked by web
browsers or ad blockers. It can not be blocked. Server-side tracking means server to

server tracking. The web browsers do not come into the picture here.

It is important to note that | am not advocating breaking the GDPR guidelines or any
privacy laws. You still need to follow your local privacy laws and process data according
to your privacy policy. However, bear in mind that browser based tracking and cookies

will be gone. It is just a matter of time. Server side tracking is the future.

For step by step instructions on setting up GA4 via GTM server side tagging, check out

this article: How to set up GA4 via GTM Server Side Tagging

Website Audit for Universal Analytics Set up

[J 1. Browse your website thoroughly and note down what

is important

Do this to understand what needs to be tracked and to understand your client's
business. Without a deep understanding of the business, you will have a hard time
setting up SMART (Specific, Measurable, Attainable, Realistic, Timely) goals in analytics

and coming up with useful analytical insight.
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[J 1.1 Determine and note down all the website sections which should also be
tracked separately (through filtered views) like a blog, forum, etc.

[J 1.2 Determine and note down all the important visitors’ interactions (like
sign-ups, logins, downloads, button clicks, form submission, video viewing etc)

with your website. These interactions should be tracked through event tracking.

[ 2. Determine and note down all macro and micro

conversions

The website objective (or conversion) is what the website is trying to achieve. There can
be one or many purposes for which a website has been set up. These purposes can be
something like: selling products, generating leads, branding, selling advertising, building

good relationships with the target audience, customer support, etc.

The major purpose(s) of setting up a website is known as a macro conversion and other

minor purposes are known as micro conversions.

[J 3. Determine the navigational paths which can lead to

macro and micro goals conversions

Navigational paths are made up of a series of web pages which you can expect your
visitors to follow to achieve website goals like making a purchase. There can be 'N' ways
of making a purchase on a website. You will have to determine the most efficient way of
making a purchase on your website. All of this will later help you in setting up and

optimizing the funnel pages in GA.
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Please note: If you do not have administrative access to the client's website, then you
will need to ask your client's developer to give you a list of web pages that makes up the

shopping cart process and the URL of the order confirmation page.

[J 4. Set up SMART targets

Targets are numerical values through which you can measure the extent to which you
have succeeded or failed in achieving a goal. Without targets and deadlines, no goal is

unachievable.

For example, Increasing the traffic of a website is not a SMART target. Increasing the
website traffic by 50% in the next 6 months can be a SMART target. Here | would like to
point out one more thing. Do not solely depend upon your clients to decide targets for

you.

Their targets are generally not SMART ("we want to double our site revenue in the next
3 months", sounds familiar?) and you may end up looking like an incompetent
consultant to them if you follow their targets. Do your own analysis and set up realistic

targets.

[J 5. Get a written agreement from your client on the goals,
goal values, funnel pages, and targets you have
determined and are planning to track.

This will save you from any future dispute/ disagreement on conversion tracking.
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[J 6. Create an account in Google Analytics in case there is
no account set up.

Click here to create a new Google Analytics account.

[J 7. Add the new Google Analytics account to your
account.

Do this only if you already have an account in Google Analytics.

More details: https://support.google.com/analytics/answer/1009694?hl=en

Universal Analytics Account Level Setup

[J 8. Enable data sharing settings

Go to Admin > Account > Account Settings
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All accounts > Optimize Smart Live Pr...

A0 Analytics  optimize Smart Main View ~
f ADMIN USER
g
’ @ My Sites
-
aﬂ Account Settings
> >
2= Account User Management
;=

Make sure the following data sharing settings are enabled:

Google products & services
Benchmarking
Technical support

Account specialists

A I A

Give all Google sales experts access to your data and account, so you can get more

in-depth analysis, insights, and recommendations across Google products.

All of these data-sharing options help in enabling enhanced ad features (like you can use
conversion optimizer in Google Ads) and let you use Google Analytics and other Google
products to their full potential. The last two settings (‘Account Specialist’, ‘Give all
Google Sales experts...”) are especially useful to those who manage Google Analytics

360.

Ask your client/boss to review and accept the ‘Data Processing Amendment’:

Copyright Optimize Smart 2023 Page 36



=8 OptimizeSmart.com

©  Account Change History Data Processing Amendment

. If you have a business established in the territory of a member state of the E

B TrashCan territorial scope of the General Data Protection Regulation (GDPR) or if you
customer contract or the Google Analytics 360 Terms of Use with Google to
more

The Data Processing Amendment for this account has not been accepted.

Review Amendment

Click MANAGE DPA DETAILS to update or complete your data processing
where you can edit contacts and your organization's legal entities.

Do not accept the ‘data processing agreement’ on vour client’s behalf esp. without

their knowledge and written consent. This could get you in trouble as it is a legal

document.

[J 9. Get administrative privileges at the account level

Go to Admin > Account > Account User Management
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All accounts > Optimize Smart Live

A0 Analytics  optimize Smart Mai
f ADMIN USER
-
' @ My Sites
> -
% Account Settings
> >
22> Account User Management
» B
. Y AllFilters

and make sure that you have got following account permissions: Edit, Collaborate, Read
& Analyze, Manage Users. | always aim to get administrative privileges at the account
level so that | can later create goals, set up funnel pages, set up filters and use all the
features of GA. If the client doesn't have any GA account then | set up an account for

him and add myself as an account administrator.

[J 10. Grant/manage other users, access to your analytics

report

| may need to provide GA access to a number of people like my client, senior
management, etc. | generally give them 'Read and Analyze' access so that they can't
accidentally make changes to the account. You can learn more about granting users

access from here: Google Analytics User Permissions & Access Levels — Tutorial
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[J 11. Document recent important changes made to your

analytics account

Go to Admin > Account > Account Change History

All accounts > Optimize Smart Live Pr..

A0 Analytics  optimize Smart Main View
f ADMIN USER
» B
' @ My Sites
-
an Account Settings
» e
aes Account User Management
» B
. M Y AllFilters
O Account Change History
i Trash Can

Note down the important changes various account users have made recently. These
changes can be the change made to Goal tracking (like goals added or deleted), views,

filters etc. More details: https://s ort.google.com/analytics/answer/2949 ?hl=en

Universal Analytics Property Level Setup
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[J 12. Enable Users Metric in Reporting

Go to Property Settings > Enable Users Metric in Reporting

Slart in-Fage Analyucs In

Event planning Forum (UA-1509844-18)

e Embedded mode (recommended]

Full view mode
Use of full view mode is recommendec
- GA4 Setup Assistant

Google Analytics Intelligence

[ Property Settings

Search History
Google A i

s Property User Management Recent brow

Intelligence uses sea

ng data is saved in your
Delete Search History
¢ » Tracking Info
Search Console

O Property Change History
Adjust Search Console

Dd Data Deletion Reguests
User Analysis

PRODUCT LINKING Enable Users Metric in Reporting

Adds the Users metric to standard rpc

L

[=_ Google Ads Linking

ES  Adsense Linking

You can learn more about enabling the user metric in reporting from here:

https://www.optimizesmart.com/add-users-metrics-standard-google-analytics-reports

[J 13. Use Google in-page analytics

£~ chrome web store

Home > Extensions > Page Analytics (by Google)

' 1 Page Analytics (by Google)

Offered by: google.com

Yk ki 1,038 ‘ Productivity ‘ 2 800,000+ users
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By default in GA, you can't see separate click-through information for multiple links on a
web page that all have the same destination URL. Similarly, by default, you can't see
click-through information for on-page elements like buttons, menus, and actions driven

by JavaScript code. To use all of these features you need to install and use the Page

Analytics Chrome extension.

You can find more details about this chrome extension from this article:

https://support.google.com/analytics/answer/6047802?hl=en&ref topic=2558810

Note: Ignore the message saying ‘This product has been deprecated and will no longer

receive updates’.

[J 14. Add your Google Search Console account to Google

Analytics property

Go to Property Settings > Adjust Search Console

Use of full view mode is reco
- GA4 Setup Assistant
Google Analytics Intellige

[Tl| Property Settings

Search History

2%» Property User Management
Delete Search History

Tracking Info

Search Console

L) Property Change History
Adjust Search Console

Dd Data Deletion Requests
User Analysis
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Through such integration, you can view the Google Search Console (GSC) data (queries,
impressions, clicks, CTR, landing pages, etc) in the search console reports of your Google
Analytics view. You can find more details about GA and GSC integration in this article:

https://support.google.com/webmasters/answer/1120006?hl=en

[J 15. Get administrative privileges at the property level

If for some reason you can’t get administrative access at the account level, then try hard

to get administrative access at the property level.

Go to Admin > Property > Property User Management

Event planning Forum (UA-1509844-18) -
GA4 Setup Assistant

[7] Property Settings

e Property User Management

Tracking Info

and make sure that you have got following permissions: Edit, Collaborate, Read &

Analyze, Manage Users.

[J 16. Grant/manage other users, access to your analytics

property
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You can give other users access to any/all properties within an account. | generally give
‘Read and Analyze’ access to other users to avoid accidental changes made to the

property.

[J 17. Make sure that you are using Universal Analytics

tracking code

You may not know, but all Google Analytics accounts have already been auto upgraded
to Universal Analytics. But the websites which own such accounts, may still be using the
old Google Analytics tracking code (ga.js or analytics.js, which is likely hardcoded on the

website).

You need to find and remove the old Google Analytics tracking code and replace it with
the latest Universal Analytics tracking code (gtag.js). Use Google Tag manager to
implement Google Analytics tracking code. In order to install Google Analytics via Google
Tag Manager, checkout this article:

https://support.google.com/tagmanager/answer/6107124?hl=en

Related article: Difference between Google Analytics and Universal Analytics

[J 18. Verify tracking code installation

Verify that the Google Analytics tracking code is correctly installed on all of your web

pages. You can use the following tools for such verification:
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#1 Google Tag Assistant

#2 Google Tag Assistant Recording

#3 Screaming Frog SEO Spider

If you want to verify the tracking code manually, view the source code of the page and

search for ‘ga.js’ or 'analytics.js' or ‘gtag.js’ code.

Related articles:

® Google Analytics stopped working? Here are 21 ways to fix it

® Google Analytics and Google Tag Manager debugging tutorial

[J 19. Verify that you are receiving the analytics data in

your GA reports

Navigate to your website and then check the 'Real time overview' report in your Google

Analytics view.
Overview

Right now

14

active users on site

M DESKTOP M MOBILE

N
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If you don't see any data then something is wrong with your tracking code installation.
You can learn more about such verification from here:

https://support.google.com/analytics/answer/1008083?hl=en

[J 20. Configure the various ‘Tracking Info’ settings.

Go to Admin > Property column > Tracking Info > Data Collection
Event planning Forum (UA-1509844-18) v
GA4 Setup Assistant
[l Property Settings
22> Property User Management

¢ » Tracking Info

Tracking Code

Data Collection

Data Retention

and then enable ‘Data Collection for Google signals’. You can find more about Google

Signals in this article: Google Signals in Analytics — Tracking users across devices without
login

Go to Admin > Property > Tracking Info > Data Retention

And then set up the ‘User and event data retention’ setting. Turn ‘Reset on new

activity’ to ‘ON’:
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s8s D ty U M 1 .
dmb Froperlytserianagemen User and event data retention

You may change the retention period for data you send that is assoc
based on aggregated data. Google signals data (if enabled) is retain
maore)

¢ » Tracking Info

Tracking Code
Data Collection

- User and event data retention:(?) Do not automatically expire «
Data Retention -

User-ID . i S
eset on new activity: (7)
Session Settings Y- (2 1|

Organic Search Sources
Referral Exclusion List

Search Term Exclusion List

<D Property Change History

Go to Admin > Property > Tracking Info > User-ID

ANAIYTICS YOU USe (.g. NOTICE anout wnat
this data can be connected to other data
i consent from your end users, or provide t
GA4 Setup Assistant implementations and features you use.

Event planning Forum (UA-1500844-18)

« You will not upload any data that allows (
m Property Settings certain names, social security numbers, ¢
permanently identifies a particular device

=2=  Property User Management such an identifier cannot be reset).

« |f you upload any data that allows Google

¢» Tracking Info Analytics account can be terminated, anc

« You will only session stitch authenticatec
Tracking Code your end users have given consent to suc
Data Collection laws and regulations.
Data Retention

I agree to the User-ID Policy.

Session Settings

Organic Search Sources 1|

Referral Exclusion List You must agree to the policy pefore continuing.

Search Term Exclusion List

O Property Change History

) Set up the User-ID
Dd Data Deletion Requests

Create a User-ID view

Then read and agree to the User ID policy, set up the User ID and create a user ID view
by following the instructions given on the setup page. In order to do cross-device

measurements, you need to enable the user ID feature. More information about setting
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up user ID can be found here: Guide to cross-device tracking with user ID in Google

Analytics

If you want to change session and campaign timeout settings then go to

Admin > Property > Tracking Info > Session Settings

| use the following settings:

22: Property User Management . .
Session Settings

¢ » Tracking Info Timeout Handling

Tracking Code Session timeout

Data Collection

Data Retention Hours Minutes

User-ID 0 - 30 -

Organic Search Sources Campaign timeout

Referral Exclusion List

Search Term Exclusion List Months Days Hours Minutes
<0 Property Change History - o - 0 - o -

Dd Data Deletion Requests

PRODUCT LINKING

To learn more about Session and campaign timeout settings, check out this article:

Understand Session & Campaign Timeout in Google Analytics

If you want to add more search engines to the default list of Organic Search

Sources then go to Admin > Property > Tracking Info > Organic Search

Sources
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2o Property User Management

@ These settings only work with the analytics.js version of the tracking code. If you're usin
¢ Tracking Info analytics.fs from ga.js, customize these settings to match your previous configuration fc

Tracking Code
Data Collection
Data Retention

Organic Search Sources
Add more search engines to the default list of Organic Search Sources. Users arriving at your site(
your reports. Learn mare

User-ID
Session Settings The order of search engines in this list can affect how data appears in your reports.
| Organic Search Sources |
Referral Exclusion List prr———
+
Search Term Exclusion List ———
) Property Change History Search Engine Name Domain Name Query Parameter
Duck Duck Go duckduckgo.com q
Dd Data Deletion Requests

You can learn more about adding organic search sources from this help article:

https://support.google.com/analytics/answer/2795821?hl=en&utm_id=ad

To add a domain/website to the referral exclusion list go to Admin >

Property > Tracking Info > Referral Exclusion List

ADMIN USER

25» Property User Management
@ These settings only work with the
¢> Tracking Info analytics.js from ga.js, customize

Tracking Code

Referral Exclusion List
Data Collection

Exclude these domains from your referraltr
Data Retention

User-ID + ADD REFERRAL EXCLUSION
Session Settings

Organic Search Sources
I Referral Exclusion List
Search Term Exclusion List eventplanningforum.net

Domain Name

O Property Change History

You can learn more about the referral exclusion list from here: How to correctly use

referral exclusion list in Google Analytics
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[J 21. Google Analytics GDPR checklist

GDPR stands for General Data Protection Regulation. If you are processing personal data
of ‘data subjects’ then you have to comply with GDPR regardless of where you live on
this planet. There are two levels of administrative fines that can be levied (on a case by

case basis) for not complying with GDPR:
1) Up to €10 million ($12.5 million), or 2% annual global turnover (whichever is higher).
2) Up to €20 million ($24.73 million), or 4% annual global turnover (whichever is higher).

To learn more about the GDPR Checklist, check out this article:_ Google Analytics GDPR

checklist. Become GDPR compliant using GA

[J 22. Add Google Ads account to Google Analytics property

Go to Admin > Property > Google Ads Linking

Event planning Forum (UA-1509844-18) v
GA4 Setup Assistant
D Property Settings
2o Property User Management
» Tracking Info
C' Property Change History

Dc

Data Deletion Requests

PRODUCT LINKING

EJ AdSense Linking
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Through such integration, you can share the data between two accounts. You can then
analyze the behaviour of the visitors coming from your Google Ads in your Google
Analytics reports. This is something that is not possible through the Google Ads

reporting interface.

You can then also import conversions and other metrics like bounce rate, session
duration, etc from Google Analytics to Google Ads, taking advantage of enhanced
remarketing and enhanced multi-channel funnel reports. To find out more details about
Google Analytics and Google Ads integration, check out this help documentation:

https://support.google.com/analytics/answer/1033961?hl=en

[J 23. Add Google AdSense account to Google Analytics
property

Go to Admin > Property > AdSense Linking
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v Event planning Forum (UA-1509844-18) -

GA4 Setup Assistant

[ Property Settings

aes  Property User Management
< » Tracking Info

- Property Change History

Dd Data Deletion Requests

PRODUCT LINKING

=_| Google Ads Linking

B3 Adsense Linking

Through such type of integration, you can get more information about the performance
of your AdSense ads and you can use this insight to improve the performance of the ads.
More details about Google AdSense and Google Analytics integration can be found here:

https://support.google.com/adsense/answer/24959767?hl=en

[J 24. Add Google Optimize to Google Analytics property

To learn more about adding Google Optimize to Google Analytics, read this article:

https://support.google.com/optimize/answer/7008374?hl=en&ref topic=7310368

[J 25. Make sure that auto-tagging is enabled in the Google

Ads account
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As soon as you link your Google Ads account to your analytics account, auto-tagging is
enabled by default. But sometimes you may find the auto-tagging disabled (maybe

someone in the past thought of manually tagging the Google Ads URLs or didn't know
what he was playing with). When you manually tag your Google Ads URLs, the Google

Ads reports in your Google Analytics view show results only by campaign and keywords.

When you enable auto-tagging, the Google Ads reports in GA provide detailed
information about the Google Ads campaign. To enable auto-tagging in Google Ads,

check out this article: https://support.google.com/analytics/answer/1033981?hl=en-GB

Also make sure the auto-tagging is working correctly

There are many factors (like third-party redirects, encoded URLs and server settings) that
can prevent auto-tagging from working properly by dropping the GCLID parameter from
the landing page URL. A dropped GCLID parameter can cause Google Analytics to report

Google Ads traffic as organic traffic rather than paid search traffic.

Add '?gclid=test' parameter to the end of the destination URL of your Adwords ad like:

https://www.yoursite.com/?gclid=test

Copy-paste the modified URL into the address bar of your browser window and press
enter. If the URL of the resulting page doesn't display 'gclid=test' then the auto-tagging is

not working.

[J 26. Add Google Optimize to Google Analytics property

To learn more about adding Google Optimize to Google Analytics, read this article:

https://support.google.com/optimize/answer/7008374?hl=en&ref topic=7310368
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[J 27. Add the Google Merchant Center account to the

Google Ads account

The advantage of this type of integration is that not only can you use product listing ads
in Google Ads but you can also implement dynamic remarketing in Google Analytics.
More details about Google Ads and Merchant Center integration can be found here:

https://support.google.com/merchants/answer/188479?hl=en-GB

[J 28. Setup Remarketing Audiences in Google Analytics

Go to Admin > Property > Audience Definitions

PRODUCT LINKING

=_| Google Ads Linking
E5 AdSense Linking
[7] Ad Exchange Linking

B3 Al Products

Postbacks

'Y Audience Definitions

Dd Custom Definitions

Dd Data Import

Through remarketing audience in Google Analytics, you can target all those people who

abandoned your shopping cart via special ads and offers in Google Ads. More details
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about creating remarketing audiences in GA can be found here:

https://support.google.com/analytics/answer/2611268?hl=en&utm id=ad

To learn about different ways to remarket to your target audience, read this article: 100+

Google Analytics Remarketing Audiences for Retargeting

[J 29. Tag your website with enhanced ecommerce tags

You need to tag your shopping cart and checkout pages with the enhanced ecommerce
tag. If you don't tag your website with enhanced ecommerce tags then you won't be

able to implement dynamic remarketing in Google Analytics.

To learn about setting up enhanced ecommerce tracking read the following two articles:

1. Enhanced Ecommerce Tracking in Google Analytics — Tutorial
2. Set up Enhanced Ecommerce Tracking in Google Analytics

[J 30. Identify enhanced ecommerce tags as dynamic
attributes

Once you have tagged your website with enhanced ecommerce tags you then need to
identify the tags as dynamic attributes and link them to your Google Ads account. Follow
the instructions in this article to do that:

https://support.google.com/analytics/answer/6002231

You need to complete this task in order to use dynamic remarketing in Google Analytics.
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[J 31. Create custom dimensions and custom metrics

Go to Admin > Property > Custom Definitions

"f Audience Definitions

Dd Custom Definitions

Custom Dimensions
Custom Metrics

Dd Data Import

If you want to collect the type of data that Google Analytics does not automatically
collect (like phone call data, CRM data, etc) then you need to create and use custom
dimensions and metrics. You can learn more about creating custom dimensions and
metrics from this article: Complete Guide to Dimensions and Metrics in Google
Analytics

[J 32. Implement dynamic remarketing with Google

Analytics

Once you have created a remarketing audiences in GA, added custom dimensions and
created dynamic attributes, then you are in a position to implement dynamic
remarketing which lets you show remarketing ads based on the products your website
users view. You can learn more about dynamic remarketing and its implementation

from the following articles:

# Dynamic Remarketing in Google Analytics via Dynamic Attributes

# Setting up Dynamic Remarketing via Google Tag Manager

Copyright Optimize Smart 2023 Page 55


https://www.optimizesmart.com/complete-guide-to-dimensions-and-metrics-in-google-analytics/
https://www.optimizesmart.com/complete-guide-to-dimensions-and-metrics-in-google-analytics/
https://www.optimizesmart.com/100-google-analytics-remarketing-audiences-for-retargeting/
https://www.optimizesmart.com/guide-to-dynamic-remarketing-in-google-analytics-adwords/
https://www.optimizesmart.com/setting-up-dynamic-remarketing-via-google-tag-manager/

=8 OptimizeSmart.com

[J 33. Import clicks and cost data from third-party

advertising platforms

You need cost data in Google Analytics reports in order to calculate the ROl of your

non-Adwords marketing campaigns. However, in order to upload cost data, you need to
create a cost data set first, in your GA property. Without cost data set, you can’t upload
cost data into your Google Analytics property. To learn more about creating a cost data

source, read this article:_https://support.google.com/analytics/answer/6064692?hl=en

Universal Analytics View Level Setup

[J 34. Change time zone and currency settings

Go to Admin > View > View Settings

and make sure that your view has got the right time zone and currency selected and the

‘Default Page’ field is blank:
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Event planning Forum

- L5 | View Settings |

ase View User Management

F Goals

. Content Grouping

Y Filters

[%]  Channel Settinas

The currency that you select here will be used in your ecommerce reports.

Disabled

Time zone country or territory

United Kingdom « (GMT+00:00) GMT +

Default page (?) optional

Exclude URL Query Parameters optional

Currency displayed as (?)

US Dollar (USD §) ~

[J 35. Exclude query parameters from the Google Analytics

report

Go to Admin > View > View Settings

And make sure that you should exclude any query parameter(s) or unique session IDs

(e.g., sessionid or vid) that appear in your URLs and that you do not want to see in your

GA reports.
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ADMIN USER

Optimize Smart Main View

Ll ¥ | View Settings

aos  View User Management

F Goals

7. Content Grouping

%Y Filters

Read this article for more details:

https://support.google.com/analytics/answer/1010249?hl=en

Disabled

Time zone country or territory

United Kingdom ~ (GMT+00:00) United Kingdom Time ~

Default page (7) optional

Exclude URL Query Parameters optional

fbelid,page,+Provide+an+example+not
+listed+on+the+webpage.,mc_cid,cf_u

P

Currency displayed as (2)

US Dollar (USD $) ~

[J 36. Exclude all hits from known bots and spiders

(Stopping Google Analytics Spam)

Go to Admin > View > View Settings

And make sure that you click on the checkbox ‘Exclude all hits from known bots and

spiders’:
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Optimize Smart Main View

“ B | view Settings

H )

View User Management

Goals

Content Grouping

Filters

Channel Settings

Fcommerce Settings

Disabled

Time zone country or territory

United Kingdom ~ (GMT+00:00) United Kingdom Time ~

Default page (?) optional

Exclude URL Query Parameters optional

fbelid,page,+Provide+an+example+not
+listed+on+the+webpage.,mc_cidef_u

Currency displayed as (7)

US Dollar (USD $) ~

Bot Filtering
v Exclude all hits from known bots and spiders

You can learn more about bots and spiders from this article: How to Stop Google

Analytics Spam — Remove Referral Spam

[J 37. Enable internal site search tracking

Go to Admin > View > View Settings

Turn on the 'Site search Tracking' button and then enter your query parameter:
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Event planning Forum cllrrency d|sp|ayed as | z; \

US Dollar (USD §) ~

Bot Filtering
aae  View User Management ¥ Exclude all hits from known bots and spider
W Goals Site Search Settings

Site search Tracking (?) optional

}; Content Grouping n

Y Filters

Query parameter

i Channel Settings q

Strip query parameters out of URL (7)
W Ecommerce Settings pauenp -

Through an internal site search, you can determine how visitors search and what they
search for on your website. With this insight, you can determine missing contents on

your website i.e. the contents which should be there (as a lot of visitors search for it) but

are not there.

By analyzing internal search reports you can improve the quality of search results for key
phrases and develop a better user experience. You can also identify new keywords for
your search campaigns. You can learn more about setting up site search tracking from

here: Understanding Site Search Tracking in Google Analytics

[J 38. Get administrative privileges at the view level

If for some reason you can’t get administrative access even at the property level then try

very hard to get administrative access at the view level.

Go to Admin > View > View User Management

Copyright Optimize Smart 2023 Page 60


https://www.optimizesmart.com/understanding-site-search-tracking-google-analytics/

s OptimizeSmart.com

UM -+ Create View

Event planning Forum v

B View Settings

2> View User Management

W Goals

and make sure that you have got following permissions: Edit, Collaborate, Read &
Analyze, Manage Users. If you can’t get administrative access even at the view level
then look for another client. Seriously. Without administrative access, you will have a

hard time configuring the GA account in a timely manner.

[J 39. Grant/manage other users, access to your analytics
view

You can give other users access to any/all views within a GA property. | generally give

‘Read & Analyse’ access to other users to avoid accidental changes made to a view.

[J 40. Set up goals and funnel pages in your account

Go to Admin > View > Goals
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Event planning Forum -
B View Settings

aas View User Management

F Goals

And then set up all the goals and funnel pages which you discovered during your website
audit and on which your client/boss agreed upon in writing. You can find more details
about setting up goals and funnels here: Google Analytics Goals and Sales Funnels —

Tutorial

[J 41. Create/edit content groups

Go to Admin > View > Content Grouping

Event planning Forum -
B View Settings

aas View User Management

F Goals

L Content Grouping
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And create one or more content groups. A content group is simply a collection of
website content. Through content grouping, you can group your website contents and

then analyse them at the Group level.

For example, if you sell clothes, you can create content groups for men and women. So
the men's content group contains all those product pages which sell men's shirts and
trousers. To learn more about creating and editing content groups, check out this article:

Content Grouping in Google Analytics — Tutorial

[J 42. Apply filters to your view / exclude internal traffic
Go to Admin > View > Filters

VM -+ Create View

Event planning Forum -
B View Settings

25e View User Management

W Goals

. Content Grouping

Y Filters

And then create one or more filters. Make sure to add filters which keep source,
medium, campaign and search term in lowercase. And also create another set of filters
for excluding internal traffic. To learn more about excluding internal traffic, check out

this article: https://support.google.com/analytics/answer/10348407?hl=en
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To learn more about creating view filters in general, check out this article:

https://support.google.com/analytics/answer/1034823?hl=en-GB&ref topic=1032939

Note: You should also consider using the Google Analytics Opt-Out browser Add-on to
exclude internal traffic as excluding internal traffic on the basis of IP address is not a

full-proof method.

[J 43. Create at least 5 reporting views for each GA

Property

For each GA property that you are using, create at least 5 reporting views:

1. One Unfiltered view (name it Raw Data View) which contains the raw traffic data.
2. One view just for testing purposes (name it Test View).

3. One view which is used for day to day analysis (name it ‘Main View’).

4. One view which contains only organic search data (name it organic search view)

5. One view which contains data only from your target market location (name it Target

Market view)

Also, consider creating one view for each subdomain or product/content category.

Filtered views are simply views and filters used together.

Make sure that you always maintain one unfiltered view before you create filtered

views.
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This is because once the raw data has been processed by a filter, GA can't re-process the
raw data. So if you accidentally applied a wrong filter to your main view then your lost
data can't be recovered. | always create and use at least 10 views. You can learn more
about creating these views from this article: 10 Google Analytics Views that you must
always use

[J 44. Create Custom Channel Grouping

Go to Admin > View > Channel Settings > Channel Grouping

And then click on the ‘+ NEW CHANNEL GROUPING’ button:

ADMIN USER

Name
+ B View Settings

Default Channel Grouping
ass View User Management

F Goals

J. Content Grouping

Y Filters

Ill

| channel Settings

Channel Grouping

Manage Brand Terms

Channel grouping is a rule-based grouping of marketing channels.Channels groups are

created for two main reasons:

1. To change the way Google Analytics label and aggregate incoming traffic for

advanced data analysis.
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2. To quickly check the performance of a set of marketing channels or set of traffic

sources.

You can learn more about channel grouping from this article: Default and Custom

Channel Grouping in Google Analytics Explained

[J 45. Set up branded and generic paid search keywords

Through such a setup you can analyse the performance of your branded and generic

paid search keywords.

Manage Brand Terms

Event planning Forum aid Search queries. Lei
- I View Settings
Enter brand terms

2o View User Management

optimizesmart
B Goals optimize smart

optimise smart
2. Content Grouping
Y Filters

Add brand terms »

~| Channel Settings

Suggested brand terms
Channel Grouping

| Manage Brand Terms

= Ecommerce Settings

More information can be found here:

https://support.google.com/analytics/answer/6050679?hl=en&utm_id=ad
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[ 46. Enable E-Commerce and Enhanced Ecommerce

Reporting

Go to Admin > View > Ecommerce Settings

and then switch the following two toggle buttons to ‘ON:

I View Settings
Ecommerce set-up

25+ View User Management Enable Ecommerce
se the Ecommerce developer reference
h —
~ o - B
f\ Content Grouping Enable Enhanced Ecommerce Reporting
Y Filters

Checkout Labeling optional
|i Channel Settings

= | Ecommerce Settings

Dd Calculated Metrics eeTa

PERSONAL TOOLS & ASSETS

_E| = Segments
Cancel

Note: This setting only turns on the flow of ecommerce data in your report. It does not

set up ecommerce tracking or enhanced ecommerce tracking.

[J 47. Create Calculated Metrics

To create a calculated metric, go to Admin > View > Calculated Metrics

And then click on the ‘“+NEW CALCULATED METRIC’ button:
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ADMIN USER

Filters |J r Calclgted Metrics are us
v = Usealfulated metrics w

+“ .~| Channel Settings
+ NEW CALCULATED METRIC

-! Ecommerce Settings Calculated Metric Name

Dd |Calculated Metrics seTa

PERSONAL TOOLS & ASSETS

To learn more about calculated metrics, check out this article: Google Analytics

Calculated Metrics — Tutorial

[J 48. Setup Custom Segments

Custom segments are user-defined segments. To create a custom segment go to Admin

> View > Segments

™  Ecommerce Settings

Dd Calculated Metrics seTa

PERSONAL TOOLS & ASSETS

Z|z Segments

—l Annotations

To know more about setting up custom segments check out this article:
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You can also import advanced segments from Google Analytics Solution Gallery:

https://analytics.google.com/analytics/gallery/#landing/start/

[J 49. Check/create annotations

Create annotations to document important events (like the launch of a new design, blog

post, article going viral etc). To create an annotation, go to Admin > View > Annotations

Dd Calculated Metrics seTa

PERSONAL TOOLS & ASSETS

=|= Segments

| Annotations

|||| Multi-Channel Funnels Settings

You can share your annotation publicly or privately. Learn more about it here:

[ 50. Check/create attribution models

Go to Admin > View > Multi-Channel Funnels Settings

And then click on the ‘“+NEW ATTRIBUTION MODEL’ button to create a new attribution

model:
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[=] channel Settings Attributio odels

“

) Name
Dd Calculated Metrics seTa

PERSONAL TOOLS & ASSETS

§|§ Segments

’_] Annotations

Multi-Channel Funnels

thi Settings

An attribution model is a set of rules that determine how credit for conversions should
be attributed to various interactions/touch points in conversion paths. By creating and
using different attribution models you can value your marketing campaigns from

different perspectives. To learn more about creating an attribution model, read this

article: How to Create Custom Attribution Model in Google Analytics

[ 51. Create custom alerts

Go to Admin > View > Custom Alerts

And then click on the “+NEW ALERT’ button to create a new custom alert:
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ADMIN USER

E Channel Settings m

W Ecommerce Settings o
Dd Calculated Metrics BeTa

PERSONAL TOOLS & ASSETS

=|5 Segments
_l Annotations

Multi-Channel Funnels
Settings

=_| Custom Channel Grouping
BETA

W Custom Alerts

Through custom alerts, you can monitor significant variations in your site traffic and
other useful metrics like revenue. You can get automatic alerts when such variations

occur. You should download some important custom alerts from here.

Help article on creating custom alerts in GA:

https://support.google.com/analytics/answer/1033021?hl=en

[J 52. Schedule reports to be emailed automatically

A I 0 : §

B save 4, ExPORT « SHARE * EDIT %} INSIGHTS

Feb 4,2021 - Mar 5, 2021
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You can instruct Google Analytics to automatically send analytics reports to you and
others in your organization either daily, weekly, monthly or quarterly. You can also email
reports in different file formats. You can find more details about scheduling report

emails here: https://support.google.com/analytics/answer/1038573?hl=en

[J 53. Set up Custom Reports

Go to Customization > Custom Reports
And then click on the ‘+New Custom Report’ button to create a new custom report:

All accounts » Event planning Forum

A0 Analytics  Eyent planning Forum =
Home » .
. = Data Studio
v B¥ Customization

Unlock the power of yc

Dashboards Studio:

¢ Connect toall your d:
e Create interactive rey

Saved Reports e Share your insights

Custom Reports

Learn more
Custom Alerts

REPORTS Custo ports

» (O Realtime
+ New Custom Report
. Andianca

A Custom Report is a report that you create. In order to create such a report, you need
to select the dimensions (City and Browser, for example) and metrics (Sessions,
Pageviews, and Bounce Rate, for example) and decide how they should be displayed.

You must specify at least one dimension and one metric.

In order to create and manage custom reports, read this article:

https://support.google.com/analytics/answer/11513007?hl=en
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[J 54. Setup Saved Reports

[ | .
@ .-. am 0 . ﬁ
B save 4, EXPoRT < SHARE 7 INSIGHTS

Feb 4, 2021 - Mar 5, 2021

You can save any standard GA report in your reporting view by clicking on the ‘SAVE’
button at the top right-hand side of your screen. Through saved reports, you can save
any customization ( filters, advanced segments and/or secondary dimension etc) applied
to a Google Analytics report. To create/edit a saved report, check out this article:

https://support.google.com/analytics/answer/2676996?hl=en-GB

Other Universal Analytics Configurations

[J 55. Add Bing Ads to your Google Analytics property.

By default, Google Analytics does not report cost data (impressions, clicks, cost, CTR,
CPC) from Bing ads. There is no native way (native integration) to link your Bing

advertising account to your GA account.

But | prefer to address this task as 'Bing PPC - Analytics integration' to keep reminding
myself how important it is. In order to track Bing PPC campaigns in Google Analytics, you

need to put a special tracking code to Bing ad URLs.
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Say your Bing ad URL is https://www.abc.com/

Now to track the traffic coming from this URL in GA, you will have to add some variables

(known as campaign tracking variables) to this URL like:

https://www.abc.com/?utm_source=bing&utm_medium=cpc&utm_campaign=bing_sh

orts_Ads

Use the Campaign URL Builder tool:

https://ga-dev-tools.appspot.com/campaign-url-builder/ to add campaign tracking

variables to Bing ads.

[J 56. Make sure that you are tracking all types of

marketing campaigns

Make sure that you are tracking not just search marketing campaigns. If you are running
other online marketing campaigns like email campaigns, banner ads, affiliate programs,
social media campaigns (like Facebook Ads) etc then they should be tracked too

through campaign variables.

[J 57. Get organic keywords data back in Google Analytics

reports

Google Analytics, reports the majority of organic search keywords as ‘not provided'.
However, you can still get most of the ‘not provided’ keywords data back in GA. To learn

more, check out this article: What is Google Analytics Keyword Not Provided and how to

unlock it
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[J 58. Set up Event tracking

Go to Behavior > Events > Top Events report to see what events are currently being

tracked:

~ [ Behavior

Overview
Behavior Flow
» Site Content
» Site Speed
» Site Search
v Events

Overview

Pages

Events Flow

Always consider tracking clicks to external links, file downloads, scroll tracking, video
tracking, newsletter signups etc. Keep the number of event categories to 10 or less.

Don’t track unnecessary events like mouse clicks.

An event is user interaction with web page elements like videos or external links. GA
can't track such events by default, as they don't generate pageviews when they occur.
You should set up event tracking in GA to track such user interactions. To learn more

about event tracking, check out this article: Google Analytics Event Tracking Tutorial

[J 59. Set up cross-domain tracking
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If your website checkout process occurs on a different domain (quite common in the
case of affiliate websites) or your web session spans across multiple domains then you

need to set up cross-domain tracking. Check out this article for more details: Google

Analytics Cross-Domain Tracking Complete Guide

Note: You should also read this article on le Analyti kies to get a better

understanding of how cross-domain tracking works.

[J 60. Check your Google Analytics reports for Data

Sampling Issues

You need to look for data sampling issues in your reports. If you have got data sampling
issues then your metrics from ‘conversion rate’, ‘revenue’ to ‘sessions’ could be

anywhere from 10% to 80% off the mark. To read more about data sampling in Google

Analytics, read this article: Google Analytics Data Sampling — Complete Guide

[J 61. View full page URLs in Google Analytics Reports

You can view the full page URLs in GA reports by creating a view filter which appends
the hostname to the request URI. More details can be found here:

https://support.google.com/analytics/answer/1012243?hl=en
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You are doing Google Analytics all

wrong. Here is why...

| have dealt with hundreds of Google Analytics accounts in my career.

| have seen many issues, from incorrect tracking code, selecting the wrong KPIs, to

analyzing data without using custom reports or advanced segments.
But do you know the biggest issue of all in Google Analytics?....

It is the “misinterpretation of analytics data”.

Many marketers make the mistake of crediting conversions to the wrong

marketing channel.
And they seem to be making this mistake over and over again.

They give the credit for conversions to the last touchpoint (campaign, ad, search

term...).

They can’t help themselves because they believe that the Google Analytics reports

are ‘what you see is what you get’.

But they are actually ‘what you interpret is what you get’.
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This has resulted in marketers making wrong business decisions and losing money.

All the data you see in Google Analytics reports today lies to you unless you

know exactly how to interpret it correctly.

For example, let's talk about direct traffic.

All untagged or incorrectly tagged marketing campaigns, from display ads to

emails, could be reported as direct traffic by Google.

Whenever a referrer is not passed, the traffic is reported as direct traffic by

Google.

Mobile applications don’t send a referrer. Word/PDF documents don’t send a

referrer.

‘302 redirects’ sometimes cause the referrer to be dropped. Sometimes browsers

don’t pass the referrer.

During an HTTP to HTTPS redirect (or vice versa), the referrer is not passed

because of security reasons.

All such traffic is reported as direct traffic by Google.
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So on the surface, it may look like most people are visiting your website directly,

but this is not usually the case.

But this analysis does not end here because you are still not looking at the

complete picture.

People do not always access your website directly and then make a purchase

straight away.

They are generally exposed to multiple marketing channels (display ads, social
media, paid search, organic search, referral websites, email, etc.) before they

access your website directly.
Before they make a purchase.

So if you are unaware of the role played by prior marketing channels, you will

credit conversions to the wrong marketing channels.

Like in the present case, to direct traffic.

To get this type of understanding, you need to understand and implement web

analytics.

But you learn data analysis and data interpretation from web analytics and not

from Google Analytics.
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The direction in which your analysis will move will determine the direction in

which your marketing campaigns will move.

You get that direction from ‘web analytics’ and not from ‘Google Analytics’.

Web/digital analytics is not about Google Analytics (GA) or Google Tag Manager
(GTM). It is about analyzing and interpreting data, setting up goals, strategies

and KPIs.
It’s about creating a strategic roadmap for your business.

That's why the knowledge of web/digital analytics is so important.

So, what | have done is put together some completely free training for you.

This training will teach you what digital analytics really is and how | have been

able to leverage it to generate floods of new sales and customers.
| will also show you how you can copy what | have done to get similar results.

You can sign up for the free training here:

Reserve My Seat Now

| hope you find it helpful.
All the best,

Himanshu
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